Українська (ua)Русский (ru)
banner_02_ru_2
После обновления Windows программа выдает ошибку.
09 января 2018

Недавно стало известно про серьёзные уязвимости в процессорах Intel, частично в процессорах от AMD и процессорах ARM-архитектуры, которые затрагивают все распространенные операционные системы - Windows, Linux, MacOS, Android, iOS и другие. Из-за фундаментальной ошибки проектирования процессоров программы могут получать доступ к содержимому защищенной памяти на уровне ядра процессоров. Эти уязвимости назвали Meltdown и Spectre. Сейчас разработчики ОС срочно занимаются разработкой и выпуском патчей и обновлений для своих ОС.

Последние обновления Windows 10 и Windows Server 2016 закрывают эти уязвимости на уровне операционной системы, но содержат ошибки, которые блокируют работу нашей программы. Это обновления безопасности под номерами (IDs) KB4056888, KB4056890, KB4056891, KB4056892, и KB405689.

На официальном сайте (https://support.microsoft.com/en-us/help/4056891/windows-10-update-kb4056891) компания Microsoft информирует о уже известной ошибке (Known issues in this update - Известные проблемы в этом обновлении), которая возникает при установке этих обновлений:

«When calling CoInitializeSecurity, the call will fail if passing RPC_C_IMP_LEVEL_NONE under certain conditions.
When calling CoInitializeSecurity, the call may fail when passing RPC_C_AUTHN_LEVEL_NONE as the authentication level. The error returned on failure is STATUS_BAD_IMPERSONATION_LEVEL.»

Как заявляет сама компания Microsoft - «Мы работаем над решением и применим его в будущем релизе».

К сожалению, эта ошибка непосредственно влияет на работу нашей программы «АБ ОФИС 4.0».

Выглядит это следущим образом: при попытке подключения клиентской программы к серверу появляется сообщение о ошибке «Interface not supported». Мы уже знаем об этом и ищем решение этой проблемы. Поскольку это было для нас абсолютно неожиданно, то поиск решения может занять некоторое время.

Временно решить эту проблему можно удалив последние обновления от компании Microsoft. Ещё раз напоминаем список этих обновлений: (IDs) KB4056888, KB4056890, KB4056891, KB4056892, и KB405689.

Насчет другого программного обеспечения: например, Google и Mozilla Foundation уже выпустили обновления своих браузеров, которые уменшают или нивелируют возможность использования уязвимостей Meltdown и Spectre при работе своих программ.

Кстати, обновления системы безопасности для Windows 7 и Windows 8.1 ожидаются во вторник (09.01.2018). Надеемся, что Microsoft выпустит для них обновления уже без этой ошибки.